Apache NameVirtualHost *:80 has no VirtualHosts问题解决办法
当启动apache的时候,如果事件管理器出现“ApacheNameVirtualHost*:80hasnoVirtualHosts”错误时,大部分是因为修改了apache的httpd.conf配置文件,将extra/vhosts.conf文件引入到httpd.conf中了。
#Virtualhosts Includeconf/extra/httpd-vhosts.conf
httpd-vhosts.conf文件中有一句配置语句为
NameVirtualHost*:80
如果httpd-vhosts.conf中没有存在类似:
<VirtualHost*:80> ServerAdminwebmaster@jb51.net DocumentRoot"D:/WAPM/www" ServerNamewww.nhooo.com ServerAliaswww.nhooo.com ErrorLog"logs/www.nhooo.com-error.log" CustomLog"logs/www.nhooo.com-access.log"common </VirtualHost>
配置节,就会在事件管理器中出现ApacheNameVirtualHost*:80hasnoVirtualHosts错误。加上同上面的配置节就不会出现这个错误了。
热门推荐
10 感谢韩语老师祝福语简短
11 升职文案高级祝福语简短
12 花童结婚祝福语大全简短
13 向国庆送祝福语简短
14 什么寄语简短祝福语女生
15 客户回礼祝福语大全简短
16 女孩生日祝福语简短创意
17 家长回复节日祝福语简短
18 给外婆敬酒祝福语简短